คำตอบที่ได้รับเลือกจากเจ้าของกระทู้
ความคิดเห็นที่ 9
ไม่ได้ดึง ip จาก Interface ตรง ๆ แต่ไปดึงมาจาก checkip.dyndns.org ซึ่งจะมองเห็น public ip ของเราแน่ ๆ ลองดูครับ
# No-IP automatic Dynamic DNS update
#--------------- Change Values in this section to match your setup ------------------
# No-IP User account info
:local noipuser "user"
:local noippass "password"
# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "somehost.ddns.net"
# Change to the name of interface that gets the dynamic IP address
:local inetinterface "ether1"
#------------------------------------------------------------------------------------
# No more changes need
:global previousIP
:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP from web
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 3
:local result [/file get dyndns.checkip.html contents]
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "Current wan ip: currentIP = $currentIP"
# Strip the net mask off the IP address
:for i from=( [:len $currentIP] - 1) to=0 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:if ($currentIP != $previousIP) do={
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
:set previousIP $currentIP
# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
:local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info "No-IP: Sending update for $host"
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
:log info "No-IP: Host $host updated on No-IP with IP $currentIP"
}
} else={
:log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
}
} else={
:log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}
#--------------- Change Values in this section to match your setup ------------------
# No-IP User account info
:local noipuser "user"
:local noippass "password"
# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "somehost.ddns.net"
# Change to the name of interface that gets the dynamic IP address
:local inetinterface "ether1"
#------------------------------------------------------------------------------------
# No more changes need
:global previousIP
:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP from web
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 3
:local result [/file get dyndns.checkip.html contents]
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "Current wan ip: currentIP = $currentIP"
# Strip the net mask off the IP address
:for i from=( [:len $currentIP] - 1) to=0 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:if ($currentIP != $previousIP) do={
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
:set previousIP $currentIP
# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
:local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info "No-IP: Sending update for $host"
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
:log info "No-IP: Host $host updated on No-IP with IP $currentIP"
}
} else={
:log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
}
} else={
:log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}
แสดงความคิดเห็น
MikroTik : จะดูผลว่า Script ที่เขียนใส่ถูกต้องหรือไม่ เช่น อัพเดท No-Ip
ศึกษาจากอันนี้ https://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_No-IP_DNS
และได้ดำเนินการแก้ไข โดยเปลี่ยนเป็น ยูสเซอร์ noip, พาสเวิรด์ Noip และ Host ที่สร้างไว้ โดยสามาถที่จะทดสอบล็อกอินหน้าเว็ป noip เองได้
:local noipuser "myuser"
:local noippass "mypassword"
:local noiphost "myhostname.no-ip.net"
แต่บันทัดนี้ ไม่ได้แก้ไข เพราะไม่รู้ว่าจะใส่อะไรเพราะว่า ทั้ง 5 port ผมใช้ Eth1 ทำการติดต่อกับ ทรูเคเบิลโมเด็ม (ไม่ใช่ PPPoE)
# Change to the name of interface that gets the dynamic IP address
:local inetinterface "your_external_interface"
ทดสอบรัน ไปดูหน้า Log ไม่มีอะไรเกิดขั้น เลยไม่แน่ใจว่า ใส่พารามิเตอร์ไม่ครบ หรือ Script มันใช้ไม่ได้กันแน่
จึงเปลี่ยนไปทดสอบใช้คำสั่งใน terminal โดยเรียก
system script run MyNoIp-Script-Name
ใน terminal มันขึ้น no such item ครับ ผมทำถูกหรือผิดตรงไหนรบกวนแนะนำด้วยครับ