คำตอบที่ได้รับเลือกจากเจ้าของกระทู้
ความคิดเห็นที่ 1
ผมลองทำตาม รูปนะครับ
คือ R5 กับ R6 ไม่ไช้ OSPF เลยใช้แค่ RIPv2
ขอนุญาตลงรูปให้นะครับ
ดังนั้น R2, R3 ที่เชื่อมกับ RIP ก็จะต้อง มีทั้ง OSPF และ RIP
ส่วน R1 ไม่ใช้เชื่อมก็ OSPF เท่านั้น
hostname R1
!
interface FastEthernet0/0
ip address 172.168.255.225 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.168.255.229 255.255.255.252
duplex auto
speed auto
!
router ospf 1
network 172.168.255.224 0.0.0.3 area 0
network 172.168.255.228 0.0.0.3 area 0
!
ip classless
!
---------------------R2, R3 แบบเดียวกัน----------------------
hostname R2
!
interface FastEthernet0/0
ip address 172.168.255.226 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.168.255.233 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
redistribute connected
redistribute rip
network 172.168.255.224 0.0.0.3 area 0
network 172.168.255.232 0.0.0.3 area 0
!
router rip
version 2
redistribute connected metric 10
redistribute ospf 1 metric 10
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 192.168.10.0
no auto-summary
!
ip classless
!
---------------------R4, R5 แบบเดียวกัน----------------------
hostname R4
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 192.168.1.0
network 192.168.10.0
no auto-summary
!
ip classless
R5 ping ได้
คือ R5 กับ R6 ไม่ไช้ OSPF เลยใช้แค่ RIPv2
ขอนุญาตลงรูปให้นะครับ
ดังนั้น R2, R3 ที่เชื่อมกับ RIP ก็จะต้อง มีทั้ง OSPF และ RIP
ส่วน R1 ไม่ใช้เชื่อมก็ OSPF เท่านั้น
hostname R1
!
interface FastEthernet0/0
ip address 172.168.255.225 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.168.255.229 255.255.255.252
duplex auto
speed auto
!
router ospf 1
network 172.168.255.224 0.0.0.3 area 0
network 172.168.255.228 0.0.0.3 area 0
!
ip classless
!
---------------------R2, R3 แบบเดียวกัน----------------------
hostname R2
!
interface FastEthernet0/0
ip address 172.168.255.226 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.168.255.233 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
redistribute connected
redistribute rip
network 172.168.255.224 0.0.0.3 area 0
network 172.168.255.232 0.0.0.3 area 0
!
router rip
version 2
redistribute connected metric 10
redistribute ospf 1 metric 10
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 192.168.10.0
no auto-summary
!
ip classless
!
---------------------R4, R5 แบบเดียวกัน----------------------
hostname R4
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 192.168.1.0
network 192.168.10.0
no auto-summary
!
ip classless
R5 ping ได้
แสดงความคิดเห็น
ขอความรู้หน่อยครับ OSPF and Ripv2
https://www.dropbox.com/s/f1uk69qkp0v1oa6/Capture.JPG
โค้ดผมครับ
R1
configure terminal
router ospf 1
network 172.168.255.224 0.0.0.3 area 0
network 172.168.255.228 0.0.0.3 area 0
redistribute connected
exit
interface f0/0
ip address 172.168.255.225 255.255.255.252
no shutdown
interface f0/1
ip address 172.168.255.229 255.255.255.252
no shutdown
exit
exit
R2
configure terminal
router rip
network 192.168.255.232
redistribute connected
redistribute ospf 1
router ospf 1
network 172.168.255.232 0.0.0.3 area 0
network 172.168.255.224 0.0.0.3 area 0
redistribute connected
redistribute rip subnets
exit
interface f0/0
ip address 172.168.255.226 255.255.255.252
no shutdown
interface f0/1
ip address 172.168.255.233 255.255.255.252
no shutdown
interface f1/0
ip address 192.168.255.233 255.255.255.252
ip rip receive version 2
ip rip send version 2
no shutdown
exit
exit
R3
configure terminal
router rip
network 192.168.255.236
redistribute connected
redistribute ospf 1
router ospf 1
network 172.168.255.232 0.0.0.3 area 0
network 172.168.255.228 0.0.0.3 area 0
redistribute connected
redistribute rip subnets
exit
interface f0/0
ip address 172.168.255.230 255.255.255.252
no shutdown
interface f0/1
ip address 172.168.255.234 255.255.255.252
no shutdown
interface f1/0
ip address 192.168.255.237 255.255.255.252
ip rip receive version 2
ip rip send version 2
no shutdown
exit
exit
R4
configure terminal
router rip
network 192.168.255.232
redistribute connected
redistribute ospf 1
exit
interface f0/0
ip address 192.168.255.234 255.255.255.252
ip rip receive version 2
ip rip send version 2
no shutdown
interface f0/1
ip address 192.168.1.254 255.255.255.0
no shutdown
exit
exit
R5
configure terminal
router rip
network 192.168.255.236
redistribute connected
redistribute ospf 1
exit
interface f0/0
ip address 192.168.255.238 255.255.255.252
ip rip receive version 2
ip rip send version 2
no shutdown
interface f0/1
ip address 192.168.2.254 255.255.255.0
no shutdown
exit
exit